読者です 読者をやめる 読者になる 読者になる

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

ruby

nokogiriがインストールできない

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
An error occurred while installing nokogiri (1.6.8.1), and Bundler cannot continue.
Make sure that `gem install nokogiri -v '1.6.8.1'` succeeds before bundling.

xcodeのコマンドラインツールをインストールすれば解決した:

gem uninstall nokogiri
xcode-select --install
gem install nokogiri

依然xcode関係を整理したからかな?

参考: https://github.com/bundler/bundler/issues/3372